Pre Requisites

Estimated reading time: < 3 min

Before you use the app and start the installation process on your machine, this is important points to know in detail.

Tools

For Ionic-React mobile app development, you need Ionic-React development environment ready. Please follow below official links to setup your development machine.

Application build and test dependencies.

Below given are the essential dependencies that are needed to build the application and also for testing purpose i.e

  1. WordPress 4.4+
  2. WooCommerce 2.6+
  3. Latest Node version
  4. Latest Ionic CLI Version 5+
  5. Latest Capacitor CLI Version
  6. Latest Ionic React CLI
  7. Ionic Framework Version: 5+
  8. Android Studio with SDK Manager
  9. XCode 10

Application is tested in following enviroment

Was this article helpful?
Dislike 0
Views: 9

Continue reading

Previous: Objectives